Low performance of server due to high number of Lifeform techs

  • Hi,


    My account was revised because it was said that my account affected the performance of server. I don't know if the solution worked but now the problem I am having is that my performance is on the ground and worse than before. Clicking something takes up to 1 minute. Before my account was revised (almost lost 3/4 of my pre-lifeform account), performance seemed to be much much better.


    After revision, I had some time to check what was left and what was added. As I said, I lost 3/4 of pre-lifeform normal buildings, fleet, resources. Techs were kind of intact compared to pre-lifeform, however, almost all normal techs I improved during lifeform update were deleted.


    Well, there is no problem with losing most things, but some thing were added into the account, and this creates performance problem for me.


    16 planets had lifeforms and techs before revision. All my previous techs were changed to Kaelesh techs, which I only had on 1 planet before. Now it seems I have them on 19 planets. Some are zero and some are 6-10 levels as seen on screenshot. It is like this on 19 planets but they are mechas and human planets.



    Well, when I reset techs, It looks like there are different tech levels. Some are empty, some are 4-10 levels. I should say, I had way more techs levels on some techs, and none on some techs but now I have them.


    It seems techs were randomly placed and some reach up to 190 levels in total, and grand total is about 4000.


    Before revision, I had maybe 600-700 techs in total, and performance of server was much better. As I said, now it is slower than snail.


    I opened a new account just to test performance of server, and it seems it is getting worse for the account as the number of lifeform techs increases in total.




    Well, what I am trying to say, or ask for GF, is that this should be a known issue and if so, what is the solution? If this is something that they learn now, what is the solution?


    Will you keep deleting/revising my account? Please, dont do that. I am tired of it. If you will revise again, it is better I delete the whole account.


    Or if it will be revised, please ask me what I want to keep in order to test lifeform upgrade. If things will be randomly revised from account, there will be no way for me test deeply.


    Thank you.

  • Interesting. I’m not having any server issues. Before that update they did last week or the week before it was very bad but it’s been a dream since then. Usually in that 1 second range for page loading

  • Interesting. I’m not having any server issues. Before that update they did last week or the week before it was very bad but it’s been a dream since then. Usually in that 1 second range for page loading

    How many lifeform techs do you have in total?

  • Lots I’m in the top 20 in lifeform points

    It seems points do not matter. Before my account was revised, my lifeform tech points were 20 times higher than now but total number was around 600-700.


    Now the number of total techs is around 4000.


    For example, you can have 1 level each on 15 planets and it would give you 100 points. But you can have 15 level on 1 planet, and it would give you 1500 points.


    So, points are irrelevant in this situation. What seems to be causing problem is the total number of techs.

  • TLDR, lag is most likely because of highscore calc, which scales with levels.

    And, unfortunately, that includes the tech that you have researched but not 'active' in some slot.


    So, instead of having like let's say 18 lvl 30 teches per planet, you now probably have closer to 72(4 races worth) lvl 0-10 teches per planet.

    So the amount of "levels" in LF tech for you didn't change much despite the reduction...so you still get lag.

  • TLDR, lag is most likely because of highscore calc, which scales with levels.

    And, unfortunately, that includes the tech that you have researched but not 'active' in some slot.


    So, instead of having like let's say 18 lvl 30 teches per planet, you now probably have closer to 72(4 races worth) lvl 0-10 teches per planet.

    So the amount of "levels" in LF tech for you didn't change much despite the reduction...so you still get lag.

    Previously, I had around 23 billion LF tech points and less number of techs (600-700) and lag was bearable with beta14 (around 5-10 seconds).


    Now, I have 24 million points, around 4000 techs in total, lag reaches up to 1 minute.


    If server cannot handle 24 million LF tech points, what is gonna happen in live servers in 6 months, 1 year? People can achieve this much points in short time.

  • In fact, Gameforge has modified Lifeform many times, but the support for test players is still insufficient.

    E.g:

    Server speed.

    What is the data that made the changes? (They often make changes quietly and quietly)

    Some important displays are not processed.

    Resource issue <= this is common to all players.


    Since it's a test server, I don't mind the importance of the account, the question is the meaning of the test.

  • Page refresh issue that I was having (refreshing in 40-50 seconds, even sometimes 2 minutes), was solved with version 9.0.2 rc5


    I can refresh pages in 1 second or lower.